I’m back on the road! WayHay!

After three weeks of not having a car, my little car is finally mended and back up and running!

It was all down to the cam belt breaking, the pistons hit the valves, and six out of eight valves got bent!

I got the new valves and head gasket set off eBay for £51.50 including postage, and dad fitted it this weekend!

My cars back!

And here’s my car parked outside my house

Mounting Siemens Phone on Linux

Sorry for the lack of updates for a while, I’ve been busy and haven’t really had any time on my computer.

This morning my new data cable for my mobile phone, a Siemens AX72, arrived in the post, I brought this one from eBay.co.uk. This will be the third cable I have to get my phone to connect to my computer.
The other two cables didn’t work, the first was from a google search and was a serial cable. The second cable came from amazon and was USB, but this one didn’t work either!

I plugged the cable into my USB hub and the green light lit up, which was more than the last cable did, I checked dmesg and I’ve got some communication going on

[code]usb 1-1.1: new full speed USB device using address 3
drivers/usb/serial/usb-serial.c: USB Serial support registered for Generic
drivers/usb/core/usb.c: registered new driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
drivers/usb/serial/usb-serial.c: USB Serial support registered for PL-2303
pl2303 1-1.1:1.0: PL-2303 converter detected
usb 1-1.1: PL-2303 converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
drivers/usb/core/usb.c: registered new driver pl2303
drivers/usb/serial/pl2303.c: Prolific PL2303 USB to serial adaptor driver v0.10[/code]

Yes, now I just have to mount the phone!

The Siemens website has changed, and I can’t find there Mobile phone manager for Linux that I’m sure I have downloaded.

After googling around all morning I’ve found several good looking pieces of software.

The first site I came across was TuxMobil, it had a link to SieFS, I managed to install Fuse with no problems, but when it came to installing SieFS I had problems:

[code]# make
make all-recursive
make[1]: Entering directory `/home/anthony/downloads/siefs-0.5′
Making all in siefs
make[2]: Entering directory `/home/anthony/downloads/siefs-0.5/siefs’
gcc -I/usr/local/include -DFUSEINST=””/usr/local”” -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=22 -L/lib -o siefs siefs.o obex.o transport.o comm.o crcmodel.o charset.o /usr/local/lib/libfuse.a -lpthread
/usr/local/lib/libfuse.a(fuse.o)(.text+0x1392): In function `curr_time’:
/home/anthony/downloads/fuse-2.6.3/lib/fuse.c:738: undefined reference to `clock_gettime’
/usr/local/lib/libfuse.a(fuse.o)(.text+0x13e0):/home/anthony/downloads/fuse-2.6.3/lib/fuse.c:741: undefined reference to `clock_gettime’
collect2: ld returned 1 exit status
make[2]: *** [siefs] Error 1
make[2]: Leaving directory `/home/anthony/downloads/siefs-0.5/siefs’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/anthony/downloads/siefs-0.5′
make: *** [all] Error 2[/code]

Damn! Back to Google!

Wammu looks promising!

I installed Gammu as a shared library as required by python-gammu, no problem!

[code]# python setup.py build
running build
running build_ext
Package gammu not found, adding /usr/local/lib/pkgconfig to pkg-config search path
ERROR: Package gammu is too old!
You need version 1.9.20, but 1.9.19 is installed

You need installed gammu as shared library and enable pkg-config to find it.

This is done by invoking make installshared in gammu sources.[/code]

Right, okay, the latest version of gammu that I could find was 1.9.19, so I downloaded version 0.18 of python-gammu

[code]# python setup.py build
running build
running build_ext
Package gammu not found, adding /usr/local/lib/pkgconfig to pkg-config search path
error: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)[/code]

Okay, now my python installation is the problem! The only problem is that I can’t remember how I installed python, was is from source, RPM, or Rpmdrake (RPM package management software for Mandrake).
Edit: It was from Rpmdrake!

Ive got Gammu installed, Wammu is just the GUI, so I’ll just reinstall Gammu then use it from the command line!

If anyone can help me with this, or if you have any other recommendations for other pieces of software, comments are open!

I’ll post again tomorrow about what has happened, and if Moto4Lin will work, as I installed that last year for my sisters phone.